HP_MicroServer_Gen8_Setup

1 分钟读完

contact me

SmartArray设置Raid

服务器启动自检过程中,会提示按下特定的按键可以进入Intelligent Provisioning,然后进入Perform Maintenance,在Array Configuration Utility中选择硬盘配置Raid。我的环境是两个硬盘配置成了Raid1。

操作系统安装

如果想要安装Linux,并且使用上述的Raid1阵列,那么可选Linux版本就非常有限。因为目前HP只对RHEL和SUSE提供了B120i阵列卡的驱动程序。可以在 HPE 官网搜索驱动下载。

由于CentOS和RHEL的亲缘关系,RHEL的驱动在CentOS上可用。

选择驱动和OS版本的时候需要非常注意版本匹配:如 hpvsa-1.2.16-102.rhel7u3.x86_64.dd.gz 匹配 CentOS-7-x86_64-Minimal-1611.iso 这个版本,1611代表的是CentOS7u3版本,等同于rhel7u3。这个信息在 CentOS Base Distribution 可查。并且这也意味着,如果HP不出更新版本的驱动,那么我们的OS的kernel就不能升级,否则系统在启动的时候因无法找到Raid阵列就会报Panic。

安装系统的步骤大概分为如下

  1. 下载Raid阵列驱动,写入U盘(记作U盘A)
  2. 下载CentOS系统镜像,写入U盘,制作成安装盘(记作U盘B)
  3. 从U盘B启动系统,从U盘A安装驱动,一路安装完毕
  4. 在系统里锁定阵列卡驱动和内核

以下操作在MacOS上进行。

1、Raid阵列驱动U盘制作

找到U盘的盘号,假设为/dev/disk3
diskutil unmountDisk /dev/disk3
gunzip hpvsa-1.2.16-102.rhel7u3.x86_64.dd.gz
dd if=hpvsa-1.2.16-102.rhel7u3.x86_64.dd of=/dev/disk3 bs=1m
diskutil unmountDisk /dev/disk3

命令的操作方法可以参考 HPE Dynamic Smart Array B120i/B320i SATA RAID Controller Driver for Red Hat Enterprise Linux 7 (AMD64/EM64T)

2、从 这里 下载CentOS-7镜像。我的是 CentOS-7u3 Minimal-1611。这里需要注意的是最好不要使用netinstall类型的镜像,因为你可能还要在安装过程中去远程镜像源去下载安装包。

假设U盘B的盘号为/dev/disk2
hdiutil convert -format UDRW -o CentOS-7-x86_64-Minimal-1611.img  CentOS-7-x86_64-Minimal-1611.iso
mv CentOS-7-x86_64-Minimal-1611.img.dmg CentOS-7-x86_64-Minimal-1611.img
sudo dd if=CentOS-7-x86_64-Minimal-1611.img of=/dev/disk2 bs=1m
diskutil unmountDisk /dev/disk2

命令的操作方法可以参考 Cheat sheet: How to create a bootable USB key on Mac OS X for Ubuntu / Debian – Stephane Boyeau Blog

3、启动Gen8,默认机器会尝试从U盘启动,可以进入到CentOS的安装首页。然后按tab键进入启动参数编辑模式,在末尾添加 modprobe.blacklist=ahci inst.dd,回车继续。接下来的加载驱动的步骤可以参考HP ProLiant DL20 Gen9 安裝CentOS7時讀不到Raid controller卡解決辦法。这里需要特别注意的是,驱动一旦加载完毕后,要马上把U盘A拔下,这点HPE Dynamic Smart Array B120i/B320i SATA RAID Controller Driver for Red Hat Enterprise Linux 7 (AMD64/EM64T)也说了。接下来可以一路安装到底。

4、特别注意:为了防止系统安装软件的时候自动将阵列卡驱动和内核升级导致无法识别阵列卡的问题出现,我们用yum来锁定这几个软件包的升级。

sudo yum -y install yum-versionlock
sudo yum versionlock add kernel-*
sudo yum versionlock add kmod-hpvsa-*

可以参考 CentOS / RHEL: Yum Lock Package Version At a Particular Version – nixCraft

有价值的一些参考资料

留下评论

您的电子邮箱地址并不会被展示。请填写标记为必须的字段。 *

正在加载...